为Joomla安装CiviCRM

2020年12月31日19:37:30 发表评论 56 次浏览

介绍

了解如何为Joomla安装CiviCRM。 CiviCRM是一种流行的开源CRM, 特别适合非营利组织使用。 CiviCRM可以帮助你管理捐助者基础, 跟踪筹款活动等等。 Joomla是一个内容管理系统(CMS), 数百万人使用它来创建和管理他们的网站。

有两种安装CiviCRM的选项:

  • 在新服务器上(推荐)。CiviCRM可作为Drupal的即用型应用程序使用, 构建后即可自动安装在服务器上。
  • 在现有服务器上。可以在现有服务器上手动安装和配置CiviCRM。

要求

要在现有服务器上安装:

  • 运行Linux(CentOS 7或Ubuntu 14.04)的云服务器
  • Joomla版本2.5+
  • PHP版本5.3+
  • MySQL版本5.1+

注意:默认情况下, Apache, PHP和MySQL / MariaDB已安装并在标准Linux安装上运行。如果你的服务器是在最少安装的情况下创建的, 则在继续之前, 你将需要安装和配置Apache, PHP和MySQL / MariaDB。

在新服务器上安装CiviCRM(推荐)

登录到云面板然后去基础架构>服务器.

安装civicrm

请点击+创建创建一个新服务器。

安装civicrm

设置服务器的名称, 然后单击要使用的服务器配置。

安装civicrm

点击应用领域标签。

安装civicrm

点击搜索图标, 然后搜索CiviCRM。

安装civicrm

请点击CiviCRM.

安装civicrm

请点击创造建立服务器。

安装civicrm

服务器将被构建。

在现有服务器上安装CiviCRM

PHP版本

在命令行中, 转到你的Web目录并创建一个phpinfo.php文件:

sudo nano phpinfo.php

将以下内容放入此文件:

保存并退出文件, 然后在Web浏览器中查看文件。 PHP版本将显示在页面顶部。

PHP版本

在上面的示例中, 服务器正在运行PHP 5.4.16版本。

注意:为了安全起见, 完成后请删除此文件。

MySQL / MariaDB版本

要检查你的MySQL / MariaDB版本, 请使用以下命令登录到客户端:

sudo mysql -u root -p

版本号将显示在欢迎消息中。

MySQL版本

在上面的示例中, 服务器正在运行MySQL版本5.5.47。

Apache版本

你可以使用以下命令找到你的Apache版本:

  • CentOS和Red Hat:须藤httpd -v
  • Ubuntu和Debian:须藤apache2 -v

这将返回有关你的Apache服务器的信息。

Apache版本

在上面的示例中, 服务器正在运行Apache 2.4.6版。

从管理界面安装

安装CiviCRM的最简单方法是通过管理界面。

使用超级用户登录名登录到你的Joomla管理区域。点击安装扩展.

点击从URL安装标签。

安装CiviCRM:单击从URL安装选项卡

从获取下载URL当前的CiviCRM发布页面。向下滚动, 直到找到Joomla发布文件。它将有乔姆拉在名字里。 (请勿下载Drupal版本。)

例如, 本文发布时Joomla的最新版本是civicrm-5.4.1-joomla.zip.

右键单击Joomla版本的链接, 然后选择"复制链接位置"。你可以通过单击Shift +插入将该URL粘贴到命令行中。

将此URL粘贴到字段中, 然后单击检查并安装.

安装CiviCRM:粘贴URL

将安装CiviCRM。

一盏木

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: